Blog entries categorized under

Posted by on in News

In Joomla! 2.5.1 the issues i have written here are still exists.

If you update from Joomla! 2.5.0 to 2.5.1 you need to download the current build of the JYAML System Plugin (Version 4.0.1) and re-install it.
After this, the issues solved again.

Btw.: My Pull Requests of these bugs are commited and fixed on the Joomla! Platform on Github. I hope it will be merged to the Joomla! CMS in the next version.

Continue reading

Posted by on in Releases

This release comes with minor bug-fixes and specific patch files for Joomla! 2.5.0.

In the last blog entry i have written Joomla! 2.5.0 has a bug in the template installer.
There are patch files included in in the JYAML system plugin for this issues. These files will be automatically patched on install.

JYAML 4.0.1 Stable contains 2 Bug-Fixes and 1 Feature request and from the tracker:

  • Bug [#41]: CSS/JS (all static files) are not loaded.
  • Bug [#44]: Image output are destroyed if a component use format=raw
  • Feature [#43]: Support for NoNumber AdvancedModule
  • TODO [#42]: Check is working with Joomla! 2.5 (including patch files for Joomla 2.5.0 template installer and styles view)

Update Note:
Before update to JYAML 4.0.1 make sure you have already updated to Joomla! 2.5.
And always make a backup of your template folder. Your changes can be lost. 

If you currently can't (or not want) update to Joomla! 2.5.0,
or when you still have issues like dublicate template styles or database entries, 
you can re-install only the JYAML System Plugin and the JYAML Library later again to install the specific Joomla! 2.5.0 patch files.

Please read the section Installation & Updates in the documentation how update your template.

Continue reading

Posted by on in News

First of all...

Joomla! 2.5.0 has issues within the template and package installer!

I recommend to wait for the next Joomla! 2.5 version. I hope the fixes are included in 2.5.1.
Of course, you can use Joomla! 2.5.0 on a new installation, but it is dangerous if you update a existing template or a package includes a template.
This is a general issue and not only affected with JYAML. 

You can follow the sate of the bugs on Github:

If you want to update to Joomla 2.5.0. And when you need to update JYAML, you must do following steps.

  1. Update only the JYAML Framework Library (manually or within the extension manager)
  2. Update only the JYAML Framework System Plugin (manually or within the extension manager)
  3. Do not update the JYAML Template or the Package. If you do this, the template can be overwritten, your changes can be lost and Joomla create duplicate database entries.
  4. At least, open the template settings in the template manager, open the Upgrade tab and proceed the upgrade as described in the documentation.

JYAML and the great new YAML4 Framework

I'm currently work hard to implement YAML4. I do all and make many notes to make a update script to replace major things from YAML3. 

JYAML with YAML4 becomes the Version 4.5.0. I hope to i can release the version at end of February.

If you have made a template with JYAML4.0, with many adjustments you can send me your template folder as archive via E-Mail, if you would.
Because i need this to test the update script.

Continue reading

Posted by on in Releases

The Joomla! Template Framework JYAML 4.0.0 for Joomla! 1.6+ now has reached the Stable status.

JYAML 4.0.0 Stable contains some Bug-Fixes for Joomla! 1.7, improvements and minor updates. The documentation for JYAML 4.0.0 also was updated.

Minor changes:

  • Menu Subtitles now configurable in each menu item in the settings. The subtitle separator (like ##) was removed. This means, no page/menu title issues with other extensions.
  • The Count Empty Modules option now is also available in each module. So you can enable it, e.g. a module contains no real content or is not counted for some other reasons.

New in stable:

Continue reading

Posted by on in Releases

The Joomla! Template Framework JYAML is now available as Release Candidate 2.

Very important: Please read the update notes below before update.

JYAML 4.0.0 RC2 contains 5 Bug-Fixes and 1 new Feature from the tracker:

And for now the first version of the documentation for JYAML 4.x is available in German and English.

Also in JYAML 4.0.0 RC2 a template upgrader is integrated. This makes updates of necessary and new files easier.

Update notes from JYAML 4.0.0 RC1 to 4.0.0 RC2

At first, please update the JYAML System Plugin (plg_system_jyaml.zip) only, before update all other JYAML extensions. If you not do this, all template files will be overwritten and all your changes will be lost forever, because a Bug in the Joomla! install adapter. The JYAML System Plugin from 4.0.0 RC2 prevent this bug.

When you have successful installed the JYAML System Plugin you can proceed the update.
Please read the section Installation & Updates in the documentation how update your template.

Continue reading