Posted by on in News

Joomla! 2.5.0 and YAML4

First of all...

Joomla! 2.5.0 has issues within the template and package installer!

I recommend to wait for the next Joomla! 2.5 version. I hope the fixes are included in 2.5.1.
Of course, you can use Joomla! 2.5.0 on a new installation, but it is dangerous if you update a existing template or a package includes a template.
This is a general issue and not only affected with JYAML. 

You can follow the sate of the bugs on Github:

If you want to update to Joomla 2.5.0. And when you need to update JYAML, you must do following steps.

  1. Update only the JYAML Framework Library (manually or within the extension manager)
  2. Update only the JYAML Framework System Plugin (manually or within the extension manager)
  3. Do not update the JYAML Template or the Package. If you do this, the template can be overwritten, your changes can be lost and Joomla create duplicate database entries.
  4. At least, open the template settings in the template manager, open the Upgrade tab and proceed the upgrade as described in the documentation.

JYAML and the great new YAML4 Framework

I'm currently work hard to implement YAML4. I do all and make many notes to make a update script to replace major things from YAML3. 

JYAML with YAML4 becomes the Version 4.5.0. I hope to i can release the version at end of February.

If you have made a template with JYAML4.0, with many adjustments you can send me your template folder as archive via E-Mail, if you would.
Because i need this to test the update script.

Trackback URL for this blog entry.